Open RIA Services User Support Troubleshooting Silverlight project not generating code  Viewed 8382 time(s), 4 post(s)., 11/27/2015 3:49:39 PM - by StormRider01

StormRider01
StormRider01 11/27/2015 3:49:40 PM

It appears that I have the same problem referenced here: http://www.openriaservices.net/MonoX/Pages/SocialNetworking/Discussion/dtopic/F9UPYOe_kE2uUaT0AVrfUw/Web-Built-but-I-cant-seem-to-reference-the-web-from-the-silverlight-project/

I've updated the Silverlight project file: <LinkedOpenRiaServerProject>..\Manager.Web\Manager.Web.csproj</LinkedOpenRiaServerProject>

I've replaced the packages in my web project:

  <package id="OpenRiaServices.Endpoints" version="4.4.0.1" targetFramework="net46" />
  <package id="OpenRiaServices.EntityFramework" version="4.4.1.0" targetFramework="net46" />
  <package id="OpenRiaServices.Server" version="4.4.1.0" targetFramework="net46" />

I've replaced the packages in my silverlight project:
  <package id="OpenRiaServices.Client" version="4.4.0.0" targetFramework="sl5" />
  <package id="OpenRiaServices.Client.CodeGen" version="4.4.0.0" targetFramework="sl5" />
  <package id="OpenRiaServices.Client.Core" version="4.4.0.0" targetFramework="sl5" />

After Clean Solution / Rebuild Solution I have an empty Generated_Code folder in my silverlight project. 
What's the next step in debugging this issue?

This content has not been rated yet. 
20 Reputation 2 Total posts
1
Michael
Michael 12/21/2015 4:10:11 PM

Hi,

I'm having the same problem, server is compiling good but not my client models. I follow all migration tips from WCF RIA to OpenRia but the generated code on client side is still not generated.

The only thing I have while compiling the client project is this :

packages\OpenRiaServices.Client.CodeGen.4.4.1.1\build\OpenRiaServices.Client.CodeGen.targets(302,5): warning : The following exception occurred creating the MEF composition container:

packages\OpenRiaServices.Client.CodeGen.4.4.1.1\build\OpenRiaServices.Client.CodeGen.targets(302,5): warning : Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

packages\OpenRiaServices.Client.CodeGen.4.4.1.1\build\OpenRiaServices.Client.CodeGen.targets(302,5): warning : The default code generator will be used.

It seems that the 'CreateOpenRiaClientFilesTask' is generating those warnings.

Could you help me because I can't fix this issue since I upgraded my solution to SL5 / EF 6 / Open RIA / .NET 4.6...

Thank you,

Michael

This content has not been rated yet. 
20 Reputation 2 Total posts
2
StormRider01
StormRider01 1/21/2016 2:50:21 PM

I've completely given up on open ria services, and silverlight. This is a dead donkey and it's time to move on.

This content has not been rated yet. 
20 Reputation 2 Total posts
3
Daniel-Svensson
Daniel-Svensson 2/7/2016 12:18:58 PM

When you get MEF composition problems it is probably something wrong with the setup of the server project setup.

To troubleshoot you need to see the LoaderExceptions message.

I don't remember if you can set the build output verbosity in VS to debug in order to see it or if you need to debug the code generation (see https://openriaservices.codeplex.com/wikipage?title=Debugging%20Open%20Ria%20Code%20generation%20source&referringTitle=Documentation  

This content has not been rated yet. 
338 Reputation 44 Total posts
4