Open RIA Services User Support Service not found when deploying to production.  Viewed 18613 time(s), 2 post(s)., 7/14/2014 2:39:36 AM - by sumptert

sumptert
sumptert 7/15/2014 2:27:44 AM

I have a Silverlight project which I have deployed to a production server.  When I try and access the svc (url from fiddler) it doesn't exist and I get a 404 Not Found Error.

Can you please tell me what I need to look at to get it working please..

dll's are in the bin directory of the aspx site.

dll's are in the ClientBin/xap file.

I know if I can open the svc then I can troubleshoot any other issues there may be- but I am not getting any errors other that the

Load operation fail for query 'LoginUser' [HttpWebRequest_WebException_RemoteServer] Arguments NotFound

 There are no errors in the Event Logs and the IIS Logs just list the URLs

Windows Server 2012 & IIS 8,5

What do I need to do to set up IIS - Is there something I need to Install?

ERORR:

   at OpenRiaServices.DomainServices.Client.OperationBase.Complete(Exception error)

   at OpenRiaServices.DomainServices.Client.LoadOperation.Complete(Exception error)

   at OpenRiaServices.DomainServices.Client.DomainContext.CompleteLoad(IAsyncResult asyncResult)

   at OpenRiaServices.DomainServices.Client.DomainContext.<>c__DisplayClass1b.<Load>b__17(Object param0)

Caused by: [HttpWebRequest_WebException_RemoteServer]

Arguments: NotFound

Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.30214.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer


   at OpenRiaServices.DomainServices.Client.WebDomainClient`1.EndQueryCore(IAsyncResult asyncResult)

   at OpenRiaServices.DomainServices.Client.DomainClient.EndQuery(IAsyncResult asyncResult)

   at OpenRiaServices.DomainServices.Client.DomainContext.CompleteLoad(IAsyncResult asyncResult)

Caused by: [HttpWebRequest_WebException_RemoteServer]

Arguments: NotFound

Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.30214.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer


   at System.Net.Browser.AsyncHelper.BeginOnUI(SendOrPostCallback beginMethod, Object state)

   at System.Net.Browser.BrowserHttpWebRequest.EndGetResponse(IAsyncResult asyncResult)

   at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelAsyncRequest.CompleteGetResponse(IAsyncResult result)

Caused by: [HttpWebRequest_WebException_RemoteServer]

Arguments: NotFound

Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.30214.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer


   at System.Net.Browser.BrowserHttpWebRequest.InternalEndGetResponse(IAsyncResult asyncResult)

   at System.Net.Browser.BrowserHttpWebRequest.<>c__DisplayClassa.<EndGetResponse>b__9(Object sendState)

   at System.Net.Browser.AsyncHelper.<>c__DisplayClass4.<BeginOnUI>b__0(Object sendState)

This content has not been rated yet. 
53 Reputation 4 Total posts
1
GrindEspresso
GrindEspresso 6/8/2015 7:25:06 AM

Is there a solution for this? Did it ever get fixed?

This content has not been rated yet. 
20 Reputation 2 Total posts
2