Open RIA Services User Support OpenRiaServices.DomainServices.Tools' or one of its dependencies  Viewed 20631 time(s), 3 post(s)., 1/22/2015 7:11:43 AM - by sumptert

sumptert
sumptert 1/22/2015 7:11:43 AM

I have unstalled the new Nuget version of OpenRia.DomainServices.Signed.Server  and I now get the following error and I do not know how to resolve it.

The "OpenRiaServices.DomainServices.Tools.ValidateDomainServicesTask" task could not be loaded from the assembly OpenRiaServices.DomainServices.Tools. Could not load file or assembly 'OpenRiaServices.DomainServices.Tools' or one of its dependencies. The system cannot find the file specified. Confirm that the <UsingTask> declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask.

I have tried manually adding the tools.dll from the server packge tools directory but the error still occurs

Recreate Issue:  New WebAPI Project - Install nuget package  compile.

This content has not been rated yet. 
53 Reputation 4 Total posts
1
ColinBlair
ColinBlair 1/27/2015 2:43:17 PM

Unload the project and then edit the project file. The task entry should be near the end of the file. Nuget is supposed to remove the entry when you remove the package but it sounds like it failed to do that.

Rated 4.00, 1 vote(s). 
1539 Reputation 130 Total posts
2
sumptert
sumptert 1/28/2015 2:50:45 AM

That fixed it thank you

This content has not been rated yet. 
53 Reputation 4 Total posts
3