Open RIA Services User Support Migrating to OpenRIAServices  Viewed 20093 time(s), 2 post(s)., 5/22/2014 12:06:12 PM - by ROBALEXCLARK

ROBALEXCLARK
ROBALEXCLARK 5/22/2014 12:06:12 PM

Hi folks,

I'm trying to migrate my ye olde RIA services project to the new fangled openRIAServices but hitting problems getting it to compile. Here's what I've done

1) Removed the RIAServices for code first, RIAServices.Server & Entity Framework packages

2) Installed Open RIA Services for EF 6, Open RIA Sercices.Server and EF 6 nuget packages into the .web project

3) Installed the Open RIA Servces full client nuget package into the client project (not sure why this is needed)

4) Fixed up all the broken namespaces and got the .web project to compile correctly

5) Restarted VS

Despite doing the above my client project won't compile, with lots of errors saying it can't find the server side entities, for example:

The type or namespace name 'Activity' could not be found (are you missing a using directive or an assembly reference?)

Its like the client project can't resolve the server side entities any more.

Any ideas how to fix this?

</br>

This content has not been rated yet. 
76 Reputation 9 Total posts
1
ROBALEXCLARK
ROBALEXCLARK 5/22/2014 12:37:00 PM

Sorry folks, after I had read thru the entirety of the blog post:

http://www.openriaservices.net/blog/post/The-Open-RIA-Services-Blog/1017/Porting-from-WCF-RIA-Services-to-Open-RIA-Services/

I managed to get it working

This content has not been rated yet. 
76 Reputation 9 Total posts
2